Answer for RTSP not working after HLS stream aliasing mechanism

paresh wrote:
rjimenez wrote:
Hello, Please do note that your HLS stream has its corresponding groupname. The alias involved in groupNameAlias has its corresponding groupName because it is the one being aliased. In your test steps, just to make sure the alias is generated properly, would it be possible for you to call the listGroupNameAliases command in server B after step 4, and see if the generated string is present in the groupNameAliases together with the correct corresponding groupName? If the said string (alias) together with the groupName is not present, then there must be something wrong in the alias generation. I would be curious as to how exactly this server A receives this string from server B, and how exactly this server B generates the alias with a random string.
1. Question : would it be possible for you to call the listGroupNameAliases command in server B after step 4, and see if the generated string is present in the groupNameAliases together with the correct corresponding groupName? Answer: It is possible, but it’s not needed here, as alias is successfully generated. How I know that It is successfully generated or not, I parse response from Evostream Media Server, and gets success. In worst case, if it is not generated properly, it is handled in Server B itself, and respective response is passed to server A. 2. Question : I would be curious as to how exactly this server A receives this string from server B Answer: Response can be of two types from Server B to Server A: a) If there’s any error in generating alias, Server B will send "Alias not generated" b) If it is success, server B will send the generated alias On the type of response from Server B, further processing is done in Server A. 3. Question: how exactly this server B generates the alias with a random string. Answer: a) First Server B generates a random string b) Once the random string is generated, passes the same string to evostream server in http api on port 7777
Ok now. I have some more questions. You have your hls streams created before generating a groupNameAlias right? May I know how you created your HLS Streams? You said before that when groupNameAliases and streamAliases were both enabled, you couldn’t play your rtsp streams right? Now, you tried having groupNameAliases enabled, but streamAliases disabled.. what is the outcome? The HLS streams won’t play? RTSP streams, playing?

Offcanvas

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.