Ingest RTMP Stream

Ingest RTMP Stream

Support ForumCategory: GeneralIngest RTMP Stream
chadcrabb asked 7 years ago
I am trying to ingest an rtmp stream.  I am using a software called ManyCam, but I have also tried this with OBS. In the config, I have set:
Start your code here
hasIngestPoints=true I then used the API to create an Ingest Stream.  In ManyCam I entered: Server: rtmp:// Stream Key: theIngestPoint But I can’t get this to work.  All I see in the logs are: SyntaxEditor Code Snippet
1490659380:3:..\..\..\sources\thelib\src\netio\iocp\tcpacceptor.cpp:227:TCPAcceptor::Accept:Inbound connection accepted: (Far:; Near: CTCP(544) <-> TCP(25) <-> [IR(26)]
1490659380:6:..\..\..\sources\thelib\src\protocols\rtmp\basertmpappprotocolhandler.cpp:835:BaseRTMPAppProtocolHandler::ProcessInvokeConnect:User agent `FMLE/3.0 (compatible; FMSc/1.0)` on connection (Far:; Near: CTCP(544) <-> TCP(25) <-> [IR(26)]
1490659380:3:..\..\..\sources\thelib\src\protocols\rtmp\basertmpappprotocolhandler.cpp:962:BaseRTMPAppProtocolHandler::ProcessInvokePublish:NetStream.publish("theIngestPoint","live") called on (Far:; Near: CTCP(544) <-> TCP(25) <-> [IR(26)]
1490659380:2:..\..\..\sources\thelib\src\protocols\rtmp\basertmpappprotocolhandler.cpp:977:BaseRTMPAppProtocolHandler::ProcessInvokePublish:No ingest point found for theIngestPoint on (Far:; Near: CTCP(544) <-> TCP(25) <-> [IR(26)]
1490659380:6:..\..\..\sources\thelib\src\application\baseclientapplication.cpp:385:BaseClientApplication::UnRegisterProtocol:Protocol (Far:; Near: CTCP(544) <-> TCP(25) <-> [IR(26)] unregistered from application: evostreamms
1490659380:4:..\..\..\sources\thelib\src\netio\iocp\iohandlermanager.cpp:126:IOHandlerManager::UnRegisterIOHandler:Handlers count changed: 26->25 IOHT_TCP_CARRIER
  Any ideas?  I thought this would be a pretty standard setup.  

3 Answers
rjimenez answered 7 years ago
I think in your use case, you do not need to set hasIngestPoints=true. Try doing the same test steps without editing the hasIngestPoints=true parameter in the config.lua, set it to its default value which is false instead. Once you’re able to push your stream from ManyCam or OBS to EMS, call the liststreams telnet API command, you’ll see the ingested stream if successfully done.
rjimenez answered 7 years ago

Or if you really need the ingestPoints functionality of EMS, you should create ingest points first before you’re able to push a stream from ManyCam/OBS to EMS. You can find information regarding this feature in our documentation. But as for the basic functionality, you can already manage the normal ingestion without setting hasIngestPoints=true.

chadcrabb answered 7 years ago
Thank you for the tips, it worked!  I was a little confused by the instructions in the documentation.  It said to turn on hasIngestPoints.  For some reason this makes it not work for me.  Setting it to “false” works though.   Thanks again!


Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.