Multiple Evostream Web Server Issues

Multiple Evostream Web Server Issues

Support ForumCategory: GeneralMultiple Evostream Web Server Issues
admin Staff asked 8 years ago
Hello, I have been unable to get 2 items working with the Evostream Web Server and have been unable to find an adequate amount of documentation regarding the web server to discover the source of the issue. First, I have seen elsewhere in the forum that I can add the following snippet,

includeResponseHeaders=
{
   {
      header="Access-Control-Allow-Origin",
      content="*",
      override=true,
   },
},
to get the web server to include the above header. However, inserting the node at BOTH the supportedMimeTypes and webRootFolder, neither have worked. I still do not get the header. In what version of Evostream was this feature added? Second issue: I have been unable to get the "StreamingSessionStarted" and "StreamingSessionEnded" events to work. I have added the events to my existing list of events in the "enabledEvents" node in config.lua, but the event was never raised. I copied the "enabledEvents" node and pasted in the webconfig.lua file as well and am still not receiving the events. I know that EWS is serving up the media via HTTP, as I have disabled Apache and no longer see it in the HTTP header. I just can’t get the events to work or the control header. Please advise.



Offcanvas

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.