One Process \'evostreamms\' stops - Evostream hangs

Support ForumCategory: GeneralOne Process \'evostreamms\' stops – Evostream hangs
silvan Member asked 1 year ago

From time to time, sometimes only after a couple of months, we could observe that Evostream is not working properly anymore, streams not coming in from the clients anymore. When this happens, there is always the situation that one of 4 evostreamms processes is not running any longer (i think the number 4 is dependent on the number of cores).Any ideas?Thanks, Silvan

2 Answers
Don Evostream-Staff answered 1 year ago

Hi Silvan,

Could you provide the EMS logs so that we can check what happened? Could you provide the following information as well?
EMS version
OS version
Machine specs

Cheers,
Don

silvan Member answered 1 year ago

Hi Don,

Sorry, this had to be put aside but has now become an issue again. It happens now more often, about every week, but had it even twice last night.

Evostream version: evostreamms-1.7.0.4273-x86_64-Ubuntu_14.04
OS: Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-105-generic x86_64)
runs on an ESXi vSphere Hypervisor
Memory: 8GB
CPU: Intel(R) Xeon(R) CPU X5677 @ 3.47GHz
available cores: 4

About 20 recordings running

The logfiles are just a bit too large, i’ve put them on https://drive.google.com/file/d/1cA-9PGrLFH5AmL-Rh3AGOex1TR2fUwAZ/view?usp=sharing
There is one huge line in the biggest of the files, don’t know if it has anything to do with it. I could see that message a lot, though. The process which stopped automatically was 31928, after that we have a script checking if there are 4 processes running, and does an evostream restart if not.

Thanks
Cheers
Silvan