RedHat 7 evostreamms.service

Support ForumCategory: Installation and Basic OperationRedHat 7 evostreamms.service
cesar1o Member asked 2 years ago

I installed the version 1.7.1 build 4491 on RedHat 7.3 and the service don´t work after this.
I do this with yum installation instructions on http://docs.evostream.com/ems_quick_start_guide/quick_start_guide_for_linux
————————-
[root@cmal06lstb01 ~]# evostreamms –version
EvoStream Media Server (www.evostream.com) version 1.7.1 build 4491 with hash: 64b305253110afc4acd5aeaf87f0a0b0f9b53526 – PacMan|m| – (built for CentOS-7-x86_64 on 2016-06-17T03:55:17.000)
Compiled on machine: `Linux localhost.localdomain 3.10.0-229.14.1.el7.x86_64 #1 SMP Tue Sep 15 15:05:51 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux`
[root@cmal06lstb01 ~]# cd /etc/evostreamms/
[root@cmal06lstb01 evostreamms]# ls -l
total 28
-rw-r–r–. 1 root root    0 Jun 17  2016 blacklist.txt
-rw-r–r–. 1 root root 9960 Jun 17  2016 config.lua
-rw-r–r–. 1 root root 1119 Jun 17  2016 server.cert
-rw-r–r–. 1 root root  887 Jun 17  2016 server.key
-rw-r–r–. 1 root root  164 Jun 17  2016 users.lua
-rw-r–r–. 1 root root 3304 Jun 17  2016 webconfig.lua
-rw-r–r–. 1 root root    0 Jun 17  2016 whitelist.txt
[root@cmal06lstb01 evostreamms]# service evostreamms status
evostreamms is not running
[root@cmal06lstb01 evostreamms]# service evostreamms start
Starting evostreamms (via systemctl):  Job for evostreamms.service failed because the control process exited with error code. See “systemctl status evostreamms.service” and “journalctl -xe” for details.
                                                           [FAILED][root@cmal06lstb01 evostreamms]# systemctl status -l evostreamms.service
● evostreamms.service – LSB: EvoStream Media Server
   Loaded: loaded (/etc/rc.d/init.d/evostreamms; bad; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2017-06-20 11:41:38 BRT; 4s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 3198 ExecStart=/etc/rc.d/init.d/evostreamms start (code=exited, status=1/FAILURE)

Jun 20 11:41:38 cmal06lstb01.globoi.com systemd[1]: Starting LSB: EvoStream Media Server…
Jun 20 11:41:38 cmal06lstb01.globoi.com evostreamms[3198]: Starting EvoStream Media Server: [FAILED]Jun 20 11:41:38 cmal06lstb01.globoi.com systemd[1]: evostreamms.service: control process exited, code=exited status=1
Jun 20 11:41:38 cmal06lstb01.globoi.com systemd[1]: Failed to start LSB: EvoStream Media Server.
Jun 20 11:41:38 cmal06lstb01.globoi.com systemd[1]: Unit evostreamms.service entered failed state.
Jun 20 11:41:38 cmal06lstb01.globoi.com systemd[1]: evostreamms.service failed.

3 Answers
erika Evostream-Staff answered 2 years ago

Hi cesar1o ,
EMS service works fine with CentOS, can you try using a clean machine for your Red Hat? 
Did you make any changes with the config.lua/webconfig.lua file?
and could you check if EMS is running already? ps -e|grep evo
 
Thank you!

cesar1o Member answered 2 years ago

I didn’t any changes after installation and don’t have process EvoStream run.
[root@cmal06lstb01 evostreamms]# ps -ef|grep evo
root      2489  2447  0 15:19 pts/0    00:00:00 grep –color=auto evo
[root@cmal06lstb01 evostreamms]# service evostreamms start
Starting evostreamms (via systemctl):  Job for evostreamms.service failed because the control process exited with error code. See “systemctl status evostreamms.service” and “journalctl -xe” for details.
                                                           [FAILED]  
[root@cmal06lstb01 evostreamms]# ps -ef|grep evo
root      2489  2447  0 15:19 pts/0    00:00:00 grep –color=auto evo
[root@cmal06lstb01 evostreamms]# service evostreamms start
Starting evostreamms (via systemctl):  Job for evostreamms.service failed because the control process exited with error code. See “systemctl status evostreamms.service” and “journalctl -xe” for details.
                                                           [FAILED] ——————————-
Should I using CentOS 7.3 instead of RedHat 7.3?

erika Evostream-Staff answered 2 years ago

Hi cesar1o,
If you’re okay to use CentOS you may do so.. I suggest you use a clean environment as well.
Message us if you still need help.
 
Thank you!