RTSPS not supported

RTSPS not supported

deleze asked 12 months ago
Hi, Want to transport RTSP stream over SSL/TLS. The goal is to fetch a stream with FFmpeg using RTSPS. RTSPS is the only secured RTSP protocol supported by FFmpeg. RTSP over HTTPS is not supported. Evostream doesn’t support natively RTSPS. In front of the evostream I have a HAProxy as SSL end point. HAProxy configuration
global
daemon
nbproc 1
pidfile /var/run/haproxy/pid
maxconn 4096
tune.ssl.default-dh-param 1024

 stats socket /run/haproxy/admin.sock mode 660 level admin

defaults
mode http
maxconn 2000
timeout connect 5s
timeout client 50s
timeout server 120s
frontend rtsps-in
mode tcp
bind 192.168.3.222:322 ssl crt /home/sts/etc/ssl/server.pem no-sslv3
default_backend rtsp-out

backend rtsp-out
server evostream-rtsp 192.168.33.222:554


 
  I use the following FFmpeg command :
ffmpeg -loglevel trace -i 'rtsps://dev-evoserver/53f3cc73c33d27cd25ff4ad892fd181c5ce3d8a3.vod' -vcodec copy -f mp4 a.mp
The OPTION message is ok but the DESCRIBE command never return anything:
DESCRIBE rtsps://dev-evoserver:322/53f3cc73c33d27cd25ff4ad892fd181c5ce3d8a3.vod RTSP/1.0
Accept: application/sdp
CSeq: 2
User-Agent: Lavf58.12.100
  How to configure Evostream to support RTSPS? Thanks in advance, Olivier



2 Answers
_Eric_S_ Staff answered 1 month ago
Hi, Would it be possible to tweak the HAProxy to use the scheme “rtsp:” instead of “rtsps:” for the RTSP DESCRIBE parameter?

deleze answered 1 month ago
Hi Eric, Yes finally the working solution is:
frontend rtsps-in
    mode        tcp
    bind        192.168.33.222:322 ssl crt /home/sts/etc/ssl/server.pem no-sslv3
    default_backend rtsp-out-tcp
 
backend rtsp-out-tcp
    mode tcp
    server       evostream-rtsp 192.168.33.222:554
Use the mode tcp in both, frontend and backend I hope it will help.

Offcanvas

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.